Author Topic: Issues getting started on playing FF7-PC  (Read 1813 times)

codemann8

  • *
  • Posts: 55
    • View Profile
Issues getting started on playing FF7-PC
« on: 2020-04-07 22:29:30 »
I just got the 1998 PC version of FF7 and I've burned 2 full days just trying to get this working and although I'm nearly there, there are a couple of things I'm unable to figure out.  I'm also using 7th Heaven 2.0 as the launcher (I'm expecting to eventually get into modding, but I'm trying to get the vanilla game up first).  I should also mention that I'm running on Win7, and no, I'm not upgrading.

1) My PS4 controller isn't allowing DPad and L2/R2 buttons as input to the game.  It seems this is a very common problem, I see many many many posts about this and I've tried just about everything suggested in those posts, but to no success.  I'd very much prefer to use Joy2Key as I'm familiar with how to use it.  I do have all the buttons mapped to what FF7 expects from the keyboard (yes, Numpad numbers vs regular numbers) yet it seems like FF7 is trying to read from the Joystick config rather than the keyboard.  I can also verify that the Joy2Key setup is correct as I see text getting typed when I hit buttons (eventually I will change it so it only sends the keystrokes to FF7.exe so I don't have to worry about sending keystrokes to other applications).  Is there any way to disable FF7's joystick detection, it seems like that is wrongfully prioritizing the joystick over keyboard input. Or maybe there is something else I need to do.

2) The sound from the game mutes when the window isn't in focus. How can I change this? I need to be able to switch to chat or OBS but not have the interruption of audio while doing other things.

3) The graphics seem a bit choppy.  I can't quite tell if it's screen tearing or general lag, but this doesn't seem to be very clean, but it's also very slight.

4) There is a black bar on the bottom of the screen, I'm not sure if the top is getting cut off too, but is this normal?  I saw the Sticky on this, but didn't really offer any solutions that solved the issue.
« Last Edit: 2020-04-07 22:38:16 by codemann8 »

LordUrQuan

  • Alpha testing your worst nightmares
  • *
  • Posts: 602
  • LOAD "FF2J",8,1
    • View Profile
Re: Issues getting started on playing FF7-PC
« Reply #1 on: 2020-04-08 01:08:28 »
1.  Can't speak to your particular situation, but others should be able to.  There's tons of stuff here and on discord relating to getting the DS4 controller working, most importantly running the driver and key mapper as admin.
2. That's just the way it is.
3. Can't say without knowing what mods you're using and what your hardware's like.
4. That's because there is no solution (yet).

codemann8

  • *
  • Posts: 55
    • View Profile
Re: Issues getting started on playing FF7-PC
« Reply #2 on: 2020-04-08 02:02:03 »
Ugh, wow, I can't believe it was all due to something as silly as running Joy2Key as Admin. I had been running Joy2Key for years without the need for that, so I overlooked that part. I'm guessing this is required here due to FF7.exe being run as admin as well.

To answer the other part, I'm running on Win7 i7-7700K with GeForce GTX 750 Ti, drivers updated within the past month. Vanilla game with Post processing and AMD SmartBloomHDR shader (as that was recommended in a couple other threads)

LordUrQuan

  • Alpha testing your worst nightmares
  • *
  • Posts: 602
  • LOAD "FF2J",8,1
    • View Profile
Re: Issues getting started on playing FF7-PC
« Reply #3 on: 2020-04-08 13:29:56 »
To answer the other part, I'm running on Win7 i7-7700K with GeForce GTX 750 Ti, drivers updated within the past month. Vanilla game with Post processing and AMD SmartBloomHDR shader (as that was recommended in a couple other threads)
Well, your hardware's pretty close to mine (GTX 960, Core i3-4somethingorother), and I'm not getting any frame artifacts.  The big difference is that I don't have any post processing enabled, and you're mixing an AMD shader with nVidia hardware.  Try turning that off, and if that doesn't help, check your vsync status (I think the default is 'on').