Basically Mandatory > 7th Heaven

Losing my mind over issues involving EasyHook

(1/2) > >>

ZavaDabbaDoo:
Game starts without mods fine using the 7th Heaven Client. When I install mods (all mods already in there), this is what I get

### Launching Final Fantasy VII ###
Checking FF7 is not running ...
Checking FF7 .exe exists at C:\Games\Final Fantasy VII\FF7.exe ...
Verifying installed game is compatible ...
Verifying game is not installed in a System/Protected folder ...
Verifying English game files exist ...
Verifying game is full/max install ...
Creating missing required directories ...
Verifying additional files for 'battle' and 'kernel' folders exist ...
Verifying all movie files exist ...
Verifying music files exist ...
Verifying latest game driver is installed ...
   Copying C:\7th Heaven\Resources\Game Driver\GameDriver.cfg -> C:\Games\Final Fantasy VII\FFNx.cfg ...
   FFNx.dll file is up to date.
Verifying game driver shaders folders exist ...
Verifying ff7 exe ...
Checking a profile is active ...
Checking mod compatibility requirements ...
Checking mod constraints for compatibility ...
Checking mod load order requirements ...
Looking for game disc ...
Found game disc at E:\ ...
Applying changed values to registry ...
Copying ff7input.cfg to FF7 path ...
   using control configuration file [Default] Steam KB+PlayStation (Stock).cfg ...
   Copying C:\7th Heaven\Resources\Controls\[Default] Steam KB+PlayStation (Stock).cfg -> C:\Games\Final Fantasy VII\ff7input.cfg ...
Creating Runtime Profile ...
   adding paths to monitor ...
Copying EasyHook.dll to FF7 path (if not found or older version detected) ...
   skipped copying EasyHook.dll ...
   skipped copying EasyHook32.dll ...
Checking if Reunion mod is installed ...
   found: False
Launching additional programs to run (if any) ...
Writing temporary runtime profile file to C:\Users\hobbe\AppData\Local\Temp\tmp62F3.tmp ...
Attempting to inject with EasyHook ...
Failed to inject after max amount of tries (14) ...
Exception occurred while trying to start FF7 ...
Failed to launch FF7. View the above log for details.

The weirdest part is I then login to a different user (my wife) and it works FINE!

I've uninstalled and reinstalled a dozen times, and I'm so lost.

Fewtch:
This error simply occurs intermittently. Just run it a couple times until it works, its not a complete failure to run error, only a temporary one. I don't know the mechanics behind the issue, I just know you have to try to run the game a couple times for it to "hook".

Sometimes it runs first time, sometimes it take a couple tries. At leas that's been my experience.

ZavaDabbaDoo:
I hope that's the case. I ran it 6 or 7 times to no avail, but it works every single time with the same settings on my wife's windows profile.

Tsunamix:
The code 5 fix in the general settings may help

ZavaDabbaDoo:

--- Quote from: Tsunamix on 2021-04-29 00:36:11 ---The code 5 fix in the general settings may help

--- End quote ---

No dice on that either :(

Navigation

[0] Message Index

[#] Next page

Go to full version