Author Topic: Possible issue with "New Threat" mod?  (Read 2118 times)

edeneye

  • *
  • Posts: 3
    • View Profile
Possible issue with "New Threat" mod?
« on: 2019-09-23 17:56:06 »
I used 7th Heaven to mod FF7 and everything seems to work as it should, but while playtesting the game at the beginning in the mako reactor, twice now, I've gotten a strange random encounter that clearly doesn't belong at this point or place in the game. Is this a bug?


Sega Chief

  • *
  • Posts: 3964
  • These guys is sick
    • View Profile
Re: Possible issue with "New Threat" mod?
« Reply #1 on: 2019-09-23 22:32:57 »
That's a wrong encounter, which is usually caused by the scene.bin + kernel.bin not being synched with each other (this then causes the wrong encounters to be looked up and loaded). It's a common issue with 7th Heaven installs not being quite right and tends to be the first point of failure. As for fixing it, I don't know of a better way than uninstalling then reinstalling the entire thing I'm afraid; 7th Heaven is a bit temperamental because of the registry/game-conversion step.

Do you have anything else on like a translation mod for instance, that can affect the kernel as well and overwrite NT's changes to it. One way to check is to open the party menu and see if the Potion help text reads 100HP(default) or 300HP (NT). If it's 100HP then NT's changes haven't applied. If it does say 300HP though then it'll be something else.

edeneye

  • *
  • Posts: 3
    • View Profile
Re: Possible issue with "New Threat" mod?
« Reply #2 on: 2019-09-24 20:01:50 »
Well, after a reinstall, I THINK I have it sorted. I did another test play for about 20 minutes and didn't have any strange encounters. But now, the music is a little off. A new game started with no music, which started after one battle, but now the victory fanfare doesn't play. Is it recommended to activate the mods in the order shown on the 7th Heaven page, rather than activating them all and rearranging them afterwards? Or does that not make a difference?

EQ2Alyza

  • 7th Heaven Crew
  • Global moderator
  • *
  • Posts: 3198
  • Dilly-Dally Shilly-Shally
    • View Profile
    • EQ2Alyza - YouTube Channel
Re: Possible issue with "New Threat" mod?
« Reply #3 on: 2019-09-25 07:31:50 »
Activation order has no effect on the outcome. Only the load order before hitting the Launch Game button.

edeneye

  • *
  • Posts: 3
    • View Profile
Re: Possible issue with "New Threat" mod?
« Reply #4 on: 2019-09-25 23:28:49 »
Okay. Well, turns out the issue still persists. Every mod seems to work but that one. Even after multiple reinstallations and following both the text tutorial and an in-depth video tutorial. Oh well. As interesting as that mod sounds to me, I'll just have to do without. Thanks for trying to help.