Final Fantasy 7 > Troubleshooting

A plethora of problems

(1/1)

hampon_avezado:
I bought FF VII from Steam. Installed 7th Heaven Stable. And this is where my problems started.

1. New Threat doesn't work. Version 2.0 and 1.5 and the one included in Gameplay by Quimm Modd, they all break my game. It either crashes before the first cutscene, or before the first battle against the guards. The only version of New Threat that works is the 1.5 Vanilla (not always, only rarely). Although, then 7th Heaven tells me New Threat Vanilla has an update so I click update but it updates forever. The update never downloads and install, just stays there forever and I can't even cancel it without closing 7th Heaven.

2. I'm pretty sure Cosmo Memory also breaks something. I install it, and sometimes it works (introducing other bugs), sometimes doesn't and sound simply stops. Not even the menu sounds. When it works, some cutscenes still don't have audio. Like the reactor's explosion. You can't hear anything. Until later, after some dialogue, the audio resumes, then it goes away, then it comes back again. It's really bad. Also, the New Threat + Cosmo Memory combo seem to be kind of broken. I always, ALWAYS have a game-breaking bug whenever these two are installed.

I usually install Qhimm's models and SYW for textures and FMV. I don't know if this breaks anything, but I haven't had noticeable troubles with these, unless New Threat and Cosmo Memory are installed too.

I found that the New Threat bugs could be fixed if I installed the canary versions. So I updated FFNx to canary. It didn't fix anything. Game still broke before the first battle with New Threat.
I tried to update 7th Heaven to canary, but:

3. Everytime I try to update to canary, the game keep "updating" to Stable v2.3.1.0. ALWAYS. And then it tells me there is a new canary version (v2.3.1.101) and I hit update but it keeps updating to stable........

I uninstalled 7th Heaven, and downloaded Canary from Github. Now I have v.2.3.1.97 (not 101 as it says in Github). And every time it asks me update to the new canary version, v2.3.1.101, and then it installs Stable v2.3.1.0.

-.-

I have been, not hours, but days, trying to get these mods to work.

All I want is Qhimm's models, SYW's textures and FMV, New Threat 2.0 and Cosmo Memory. If this combo is impossible, I'd want someone to tell me, because I'm very near to getting a refund (which I'm not even sure Steam would give me, since I've had this game for more than 2 weeks, eventhough I have not progressed further than the train, because the audio was broken).

What can I do, man...

Navigation

[0] Message Index

Go to full version