Author Topic: 7th Heaven no longer working on Steam Deck  (Read 1183 times)

crissicks

  • *
  • Posts: 1
    • View Profile
7th Heaven no longer working on Steam Deck
« on: 2024-04-22 18:45:14 »
Hello, Im using 7th heaven with my Steam Deck with various mods installed. I cant supply a screen shot of all the mods because I can no longer get into 7th Heaven, but i was using New Threat 1.5 and various graphical enhancements.
About halfway through the game (In the Highwind and Cid just became party leader), the buttons stopped working. When I booted up the game, I couldn't proceed past the title screen.
To remedy this, I first tried turning off all of the mods. This didn't work. Then, I tried updating all of the mods as well as 7th Heaven itself (I had been getting notifications to do this but was just ignoring them). This still didn't work.
Lastly, I tried uninstalling and reinstalling Final Fantasy 7. This is when the real trouble started. Suddenly I cant even open 7th Heaven. When I try to I get a pop up that says:

You must install .NET Desktop Runtime to run this application.

Architecture: x64
App host version: 8.0.3


If I click "yes" to install this, nothing happens. I've tried going into desktop mode to install it. Still nothing.
At this point I'm getting ready to just uninstall everything and give up, but I figured I would ask here first.

I'm also wondering if I can even uninstall my mods from the Steam Deck without being able to access 7th Heaven? Im new to 7th Heaven and Linux OS.

Any help would be greatly appreciated. Thank you