Author Topic: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.  (Read 1174 times)

Jairus

  • *
  • Posts: 66
    • View Profile
7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
« on: 2021-05-28 00:12:30 »
Just what the title says. I upgraded 7H from 2.2 to 2.3 today, and whenever I try to run FF7 with Kalderasha's ChaOs mod active, I get this message:



Everything works fine with 7H 2.2, but 2.3 just keeps crashing FF7 even if ChaOs is the only active mod. I don't know what's going on. Can anyone help?

Urbanhack86

  • *
  • Posts: 7
    • View Profile
Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
« Reply #1 on: 2021-06-04 09:31:02 »
dont use 2.3, its broken and doesnt have any improvment. keep using latest 2.2 release

Bonez

  • *
  • Posts: 93
  • What goes here?
    • View Profile
Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
« Reply #2 on: 2021-07-23 09:49:18 »
dont use 2.3, its broken and doesnt have any improvment. keep using latest 2.2 release
Well that's just not true. You can explain why you think there's benefits to staying on the old version, but come on, don't spread misinformation like "it's broken and has no improvements". 2.3 stable and definitely the canaries have many fixes, improvements and features that 2.2 doesn't.  Chaos has also been fixed to work on 2.3. By all means upgrade to the latest 2.3.
« Last Edit: 2021-07-23 10:01:51 by Bonez »

Kaileecain

  • *
  • Posts: 1
  • Host of the Versian Chronicles Podcast
    • View Profile
    • Versian Chronicles Podpage
Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
« Reply #3 on: 2021-07-24 04:07:02 »
I am also running into the same error with Chaos installed. Would it help to pose the FFNx.log, or is there a new version of ChaOS coming that will solve it (I'm seeing 1.702 and having this issue)?

Edit: Using the Direct version of the mod from the Discord fixes this issue if Jairus is still looking for a fix to it. I also noticed a CTD when using Morph in combination with the DX11 Renderer, but switching to the OpenGL Renderer solved that issue.
« Last Edit: 2021-07-24 16:05:37 by Kaileecain »

Bonez

  • *
  • Posts: 93
  • What goes here?
    • View Profile
Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
« Reply #4 on: 2021-07-25 08:13:26 »
The morph thing is likely not a 7h issue.

corpse

  • *
  • Posts: 105
    • View Profile
Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
« Reply #5 on: 2021-07-30 12:05:41 »
Hi,

Just installed windows on a new ssd and tried to setup 7th heaven. Just to confirm, there seems to to a compatibility to issue with chaos and 2.3. Grabbed 2.2 from my old drive and all working. Disabling chaos  helped it launch, but then crashed on loading saves.

Thanks

Bonez

  • *
  • Posts: 93
  • What goes here?
    • View Profile
Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
« Reply #6 on: 2021-07-31 01:05:00 »
That's been fixed. Kaldarasha released this to be used with 2.3 https://mega.nz/file/DAUATTDa#nrM4nQgVN7k2h3RmKsXlohpVpBPe9OIMpYN2nOnquxw

corpse

  • *
  • Posts: 105
    • View Profile
Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
« Reply #7 on: 2021-07-31 10:54:24 »
Ok cheers, I'll give this a go.

@Bonez, can confirm all working with 2.3.

Thanks
« Last Edit: 2021-07-31 11:16:19 by corpse »