Qhimm.com Forums

Basically Mandatory => 7th Heaven => Topic started by: Jairus on 2021-05-28 00:12:30

Title: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
Post by: Jairus on 2021-05-28 00:12:30
Just what the title says. I upgraded 7H from 2.2 to 2.3 today, and whenever I try to run FF7 with Kalderasha's ChaOs mod active, I get this message:

(https://i.imgur.com/6hup1Bj.png)

Everything works fine with 7H 2.2, but 2.3 just keeps crashing FF7 even if ChaOs is the only active mod. I don't know what's going on. Can anyone help?
Title: Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
Post by: Urbanhack86 on 2021-06-04 09:31:02
dont use 2.3, its broken and doesnt have any improvment. keep using latest 2.2 release
Title: Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
Post by: Bonez on 2021-07-23 09:49:18
dont use 2.3, its broken and doesnt have any improvment. keep using latest 2.2 release
Well that's just not true. You can explain why you think there's benefits to staying on the old version, but come on, don't spread misinformation like "it's broken and has no improvements". 2.3 stable and definitely the canaries have many fixes, improvements and features that 2.2 doesn't.  Chaos has also been fixed to work on 2.3. By all means upgrade to the latest 2.3.
Title: Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
Post by: Kaileecain on 2021-07-24 04:07:02
I am also running into the same error with Chaos installed. Would it help to pose the FFNx.log, or is there a new version of ChaOS coming that will solve it (I'm seeing 1.702 and having this issue)?

Edit: Using the Direct version of the mod from the Discord fixes this issue if Jairus is still looking for a fix to it. I also noticed a CTD when using Morph in combination with the DX11 Renderer, but switching to the OpenGL Renderer solved that issue.
Title: Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
Post by: Bonez on 2021-07-25 08:13:26
The morph thing is likely not a 7h issue.
Title: Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
Post by: corpse on 2021-07-30 12:05:41
Hi,

Just installed windows on a new ssd and tried to setup 7th heaven. Just to confirm, there seems to to a compatibility to issue with chaos and 2.3. Grabbed 2.2 from my old drive and all working. Disabling chaos  helped it launch, but then crashed on loading saves.

Thanks
Title: Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
Post by: Bonez on 2021-07-31 01:05:00
That's been fixed. Kaldarasha released this to be used with 2.3 https://mega.nz/file/DAUATTDa#nrM4nQgVN7k2h3RmKsXlohpVpBPe9OIMpYN2nOnquxw
Title: Re: 7H 2.2 runs FF7 with ChaOs mod but 2.3 won't.
Post by: corpse on 2021-07-31 10:54:24
Ok cheers, I'll give this a go.

@Bonez, can confirm all working with 2.3.

Thanks