Author Topic: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions  (Read 161632 times)

Timber

  • *
  • Posts: 386
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #200 on: 2010-08-31 03:27:31 »
Some bugs with FF8:

The game seems to be running faster than usual on my PC.
I checked with Fraps and it says 31fps.

Also in battle, there appears to be feint blue boxes around the 'dust' that is kicked up when characters run.

Cheers

Also would just like to add, is there any way to make the world map textures of FF8 look like the PSX?
Would be great, as I think this is really the only thing stopping the PC version from being the superior version at this point.
« Last Edit: 2010-08-31 03:36:09 by Timber »

ItchyPanda

  • *
  • Posts: 22
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #201 on: 2010-09-03 07:28:48 »
Whenever i run FF7Config.exe it crashes...says it stopped working

Windows 7 32-bit Version

Senti

  • *
  • Posts: 79
  • There's a fine line between insanity and ingenius
    • View Profile
    • Psychopathic Studios
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #202 on: 2010-09-03 16:52:45 »
Meh, upgrade to 64bit windows ya lazy bum! Kidding, but have you tried running in compatibility mode? If not, try it, if that doesn't work then you can always add it to the registry manually. To do that you simply need to put the following in a .txt file and save it as a .reg file...

Code: [Select]
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Square Soft, Inc.\Final Fantasy VII\1.00\Graphics]
"DriverPath"="ff7_opengl.fgd"
"Driver"=dword:00000003
"Mode"=dword:00000002

You may also want to check the pseudo-crash log that it gives when it crashes and any actual crash if it saved one (which it should if it gives the popup)

ItchyPanda

  • *
  • Posts: 22
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #203 on: 2010-09-03 19:06:38 »
I guess i'll upgrade to 64bit if all of that doesnt work  :-D

Thanks

Timber

  • *
  • Posts: 386
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #204 on: 2010-09-06 04:57:33 »
Small bug report:

In the NVIDIA control panel when Vertical Sync: Force On global setting is enabled, the minigame framelimiter doesn't seem to work.
I switched back to 'Use the 3D application setting, and it was ok.

Aali

  • *
  • Posts: 1196
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #205 on: 2010-09-09 11:07:47 »
Which is a bug with your nvidia driver, but thanks anyway. Basically anything you change in any control panel is completely out of my control.

Hellbringer616

  • *
  • Posts: 1913
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #206 on: 2010-09-09 11:26:52 »
Small bug report:

In the NVIDIA control panel when Vertical Sync: Force On global setting is enabled, the minigame framelimiter doesn't seem to work.
I switched back to 'Use the 3D application setting, and it was ok.

You also can't seem to force AA, nvidia is following the route of old ATI drivers

pyrozen

  • *
  • Posts: 791
  • Team Avalanche Member
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #207 on: 2010-09-11 00:16:51 »
is there anyway to insert a "Disable Screensaver" sort of function within the driver? On both of my computers the screensaver takes over after 15 minutes(blank screen) and it's annoying as hell.  I know its not that hard to turn off the screensaver, but IIRC a few others were having a similar problem. If it's as simple as adding a bit of code it would be much appreciated, otherwise i'll continue to manually turn it off...when i remember.

lee

obesebear

  • *
  • Posts: 1385
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #208 on: 2010-09-11 05:14:11 »
is there anyway to insert a "Disable Screensaver" sort of function within the driver? On both of my computers the screensaver takes over after 15 minutes(blank screen) and it's annoying as hell.  I know its not that hard to turn off the screensaver, but IIRC a few others were having a similar problem. If it's as simple as adding a bit of code it would be much appreciated, otherwise i'll continue to manually turn it off...when i remember.

lee
I hate to take this off topic, but I have to know... why use a screensaver?

ultima espio

  • *
  • Posts: 1357
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #209 on: 2010-09-11 19:57:52 »
Would it be possible for the driver to tell us what level we are on? For example when you are on the Highwind deck it pops up with "Fship1" when the level first loads.

It would be really helpful for me and others when they are trying to edit the levels, but don't know which file that scene is in. There are multiple ones for some areas, and they all have the same text in, so its hard to tell which one is which.

Aali

  • *
  • Posts: 1196
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #210 on: 2010-09-11 21:41:13 »
pyrozen:
Your prayers have been heard. There is also the problem of computers going into various sleep states while the game is running, is this something that should be prevented as well? How do directx fullscreen apps affect this?

ultima espio:
You can already do this quite easily, show_missing_textures also tells you about field textures. Of course its not a flashy ingame message but it should do.

Zen

  • *
  • Posts: 403
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #211 on: 2010-09-11 23:39:19 »
is there anyway to insert a "Disable Screensaver" sort of function within the driver? On both of my computers the screensaver takes over after 15 minutes(blank screen) and it's annoying as hell.  I know its not that hard to turn off the screensaver, but IIRC a few others were having a similar problem. If it's as simple as adding a bit of code it would be much appreciated, otherwise i'll continue to manually turn it off...when i remember.

lee

If you have an LCD monitor (which everyone SHOULD have nowadays), screensavers are completely useless. I say turn them off.

pyrozen

  • *
  • Posts: 791
  • Team Avalanche Member
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #212 on: 2010-09-13 01:35:51 »
thanks for taking a look at this Aali, and it will go into hibernate as well. DX games seem to function perfectly, and the screensaver never appears.

As far as using a screen saver, i have some cool ones that i like. I don't care if they are "useless" on an LCD, the use for me is having a cool image moving around when i walk by.

Fischkopf

  • *
  • Posts: 217
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #213 on: 2010-09-15 18:45:08 »
v 0.7.8b made FF7Music stop working...

with 0.7.7. i had no problems and it played the psf music but with this version it plays crappy midi sound again.  :?

Overseer X

  • *
  • Posts: 21
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #214 on: 2010-09-15 21:12:21 »
When you copy and pasted the files from Aalia's 7.8 into the FF7 folder.. you replaced the ff7_opengl.cfg with the new 7.8 ff7_opengl.cfg.. so go edit that new file find - #music_plugin = plugins/ff7music.fgp and remove this  # from it. Then try FF7Music.

Let me know how that goes.

Fischkopf

  • *
  • Posts: 217
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #215 on: 2010-09-17 14:18:34 »
i deleted this line #music_plugin = plugins/ff7music.fgp and started the game but
that didn't work. it still plays the midi ingame.

ff7music spits out this:
Quote
WM_ACTIVATEAPP

INITIALIZE DD/D3D START

   2011.527 |    ERROR: [UXDriver.ApiX.Engine] [email protected]::UXDriver::ApiX::CNvApixEngine::EnsureDesktop::InputDesktop::SetThread : Could not set thread desktop to input desktop due to the following error 170.

   2011.685 |    ERROR: [UXDriver.ApiX.Engine] [email protected]::UXDriver::ApiX::CNvApixEngine::EnsureDesktop::InputDesktop::SetThread : Could not set thread desktop to input desktop due to the following error 170.

   2011.706 |    ERROR: [UXDriver.ApiX.Engine] [email protected]::UXDriver::ApiX::CNvApixEngine::EnsureDesktop::InputDesktop::SetThread : Could not set thread desktop to input desktop due to the following error 170.

   2011.708 |    ERROR: [UXDriver.ApiX.Engine] [email protected]::UXDriver::ApiX::CNvApixEngine::EnsureDesktop::InputDesktop::SetThread : Could not set thread desktop to input desktop due to the following error 170.

   2011.710 |    ERROR: [UXDriver.ApiX.Engine] [email protected]::UXDriver::ApiX::CNvApixEngine::EnsureDesktop::InputDesktop::SetThread : Could not set thread desktop to input desktop due to the following error 170.

   2011.774 |    ERROR: [UXDriver.ApiX.Engine] [email protected]::UXDriver::ApiX::CNvApixEngine::EnsureDesktop::InputDesktop::SetThread : Could not set thread desktop to input desktop due to the following error 170.

WM_ACTIVATEAPP
« Last Edit: 2010-09-17 14:24:09 by Fischkopf »

Covarr

  • Covarr-Let
  • Administrator
  • *
  • Posts: 3941
  • Just Covarr. No "n".
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #216 on: 2010-09-17 19:12:26 »
i deleted this line #music_plugin = plugins/ff7music.fgp
No. You're only supposed to delete the # at the beginning. The rest of the line should still be there.

Fischkopf

  • *
  • Posts: 217
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #217 on: 2010-09-17 20:35:54 »
Thank you now everything works. :)

djdarkneo

  • Guest
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #218 on: 2010-09-18 12:57:06 »
Hi,i have a little problem since i upgraded the ali drivers to version 0.7.8b.
First i had the remix mod with a fresh install of final fantasy vii installed and all worked fine (texture loading, 1024x768 full screen,etc...), then i tried another fresh install without the remix patch and with alis 0.7.6b drivers and all worked fine too except for some crashes at some points of the game.
This was the reason why i actually changed my drivers to the 0.7.8b but with this driver im not able to start the game.
On all versions (including the remix patcher that has alis drivers 0.7.3b) i get a start error (No useful indirect path found, search app.log for more infomation) but clicking on accept on this popup the game starts fine but on the 0.7.8b drivers after accepting the popup a new popup comes up (ooops something very bad happening.....) and the game doesnt start.I have tried the patch with a fresh install without mods and the with the remix patch but it doesnt go.
Im using the original cd version of FF7 and the disks are fine.Here is my app.log but i think its very hard to figure out what is happening.

Code: [Select]
INFO: FF7/FF8 OpenGL driver version 0.7.8b
INFO: Auto-detected version: FF7 1.02 US English
INFO: ATI Technologies Inc. FireMV 2400 PCI DDR x86/SSE2 1.3.1050 WinXP Release
INFO: Found swap_control extension
INFO: NPOT textures not supported
INFO: Max texture size: 2048x2048
INFO: Original resolution 640x480, window size 1024x768, output resolution 1024x768, internal resolution 640x480
INFO: No NPOT texture support
ERROR: init_indirect failed, scaling and postprocessing will be disabled
INFO: internal resolution clamped to 1024x768
INFO: FFMpeg movie player plugin loaded
INFO: FFMpeg version SVN-r21874, Copyright (c) 2000-2010 Fabrice Bellard, et al.
INFO: No shaders, codecs with YUV output will be slow.
INFO: FF7Music helper plugin loaded
LOCK UNLOCK TEST
ERROR: unhandled exception

Another thing, i only get the ooops crash dump error if i set my resolution to not fullscreen, if i set it to fullscreen the game simple has a black screen during 1-2 seconds and exits to desktop without giving me any error.The last string on app.log if i set it to fullscreen disappear (the unhandled exception string, the app.log ends in Lock Unlock Test)

Have tried setting resolutions like 640x480 full and not fullscreen, 800x600 full and not, 1280x800 full and not 1280x900 full and not and finally 1280x1024 full and not but my original resolution and notebooks max resolution is 1024x768 and thats the same resolution i was playing the game with older alis drivers so i think that the resolution is not the problem here.

I hope you have some ideas to help me out with this problem and sorry for my bad english, im learning it right now hehe and posting on forums and chats help very much.

Thanks and keep up making this great patch!!!

EDIT: Im using windows xp sp3 32 bit version.
« Last Edit: 2010-09-18 13:02:53 by djdarkneo »

Aali

  • *
  • Posts: 1196
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #219 on: 2010-09-18 13:05:11 »
Upload your crash.dmp somewhere so I can take a look at it.

djdarkneo

  • Guest
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #220 on: 2010-09-18 13:21:03 »
On the crash.dmp i found many strings like C:\lib\src\graphics\gl\gl_code.cpp , c:/ff7/scr/.... that i do not have on my pc. Is that normal?
I have compressed the dump file to rar and uploaded it to mediafire and megaupload (compressed file size about 780 k and uncompressed about 20 MB)

http://www.mediafire.com/?hfhzw7r8tz347x4
or
http://www.megaupload.com/?d=HT3ZZ57C

Thank you for your fast reply Ali !!!

EDIT: Remember that i get a crash.dmp file only if i set the resolution to window mode, on fullscreen i dont get errors but the game doesnt start up

EDIT 2: The only difference i see with remix patch and others is that this patch includes a eax.dll, can this bee the problem? I have copied all but i think that this dll is for ff8.
« Last Edit: 2010-09-18 13:43:45 by djdarkneo »

troyonfire

  • Guest
Aali's Patch
« Reply #221 on: 2010-09-18 13:36:05 »
Hello,

First time on the forums here. Glad I found this community. I'm having a small issue with the Aali patch.

I have followed the instructions. A) Fresh Install B) Installed 1.02 Retail Patch C) Extracted Aali's patch into the default folder location D) Ran Config and made sure it was set to "Custom" E) Modified the config file to change the screen resolution.

It appears to not be changing the screen resolution and I was hoping someone could offer some pointers.

Thank you!

Aali

  • *
  • Posts: 1196
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #222 on: 2010-09-18 14:46:40 »
The new subtractive blending feature is at fault here. The driver assumes you have support for it if you have OpenGL 1.2 but apparently thats not enough. Unfortunately there's no config option you can turn off to work around this. See if there are any updates for your graphics card drivers, they might have added support for it.

Overseer X

  • *
  • Posts: 21
    • View Profile
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #223 on: 2010-09-18 15:55:28 »
i deleted this line #music_plugin = plugins/ff7music.fgp
No. You're only supposed to delete the # at the beginning. The rest of the line should still be there.
That's what I said  :P ???

djdarkneo

  • Guest
Re: Aali's driver [v 0.7.8b] Help/Bugs/Suggestions
« Reply #224 on: 2010-09-18 16:53:39 »
The new subtractive blending feature is at fault here. The driver assumes you have support for it if you have OpenGL 1.2 but apparently thats not enough. Unfortunately there's no config option you can turn off to work around this. See if there are any updates for your graphics card drivers, they might have added support for it.

Ohhh thats bad, there are no new drivers for the graphic card (searched on dell,ati and looked over google). I will use then the older opengl drivers,it crashes but the game is playable (+ i have a save anywhere patch so that is no prob).

Thank you very much for helping me with this.